Supported Versions

Support for the following versions:

  • ThinPrint Engine 11
  • ThinPrint Engine 10.6 FR1
  • ThinPrint Engine 10.6
  • ThinPrint Engine 10

 

  • ThinPrint RDP Engine 11
  • ThinPrint RDP Engine 10
  • ThinPrint RDP Engine 9.0 – Support expires May 31, 2017

 

  • ThinPrint Desktop Engine 7.6
  • ThinPrint Desktop Engine 7.6.1

 

  • ThinPrint Personal Printing 3.0
  • ThinPrint Personal Printing Essentials 2.0 – Support expires May 31, 2017

 

Supported ThinPrint Client versions:

Most ThinPrint Clients work with most newer versions of ThinPrint Engine. An update of ThinPrint Clients thus in most cases is not required. Please contact us, if you have any questions about support of old ThinPrint Client versions.


Extend Support Period

Do you need support for older product versions or support beyond the expiration date listed?

Please contact us. We will be happy to provide a customized offer through one of our ThinPrint partners.

Contact us